Pregunta Aleteo de raíz de árbol de expansión de HP a Cisco


Según una pregunta reciente, configuré recientemente mi hardware HP (2x 2900) y Cisco (1x 3750) para usar MSTP para la interoperabilidad. Pensé que esto era funcional hasta que apliqué el cambio al tercer dispositivo (HP switch 1 a continuación), momento en el que la raíz del árbol de expansión comenzó a fallar causando problemas de rendimiento (5% de pérdida de paquetes) entre mis dos switches HP. No estoy seguro de por qué.

HP Switch 1 A4 conectado a Cisco 1/0/1. HP Switch 2 B2 conectado a Cisco 2/0/1. HP Switch 1 A2 conectado a HP Switch 2 A1. Prefiero que la pila de Cisco actúe como la raíz.

EDITAR: 


Hay una línea específica: 'spanning-tree 1 path-cost 500000' en el conmutador 2 de HP que no agregué y preexistía. No estoy seguro de si podría tener el tipo de impacto que estoy describiendo. Soy más un tipo de seguridad y monitoreo que redes.


EDIT 2:


Estoy empezando a creer que el problema radica en el hecho de que el valor para mi instancia de MST 0 en el Cisco todavía está en el valor predeterminado de 32768. Elaboré un diagrama: Spanning Tree MAC Associations  Esto se basa en cada comando de show que pude encontrar para STP. Haré este cambio después de las horas y veré si ayuda.


Cisco 3750 Config:

version 12.2

spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
 name mstp
 revision 1
 instance 1 vlan 1, 40, 70, 100, 250
spanning-tree mst 1 priority 0
vlan internal allocation policy ascending

interface TenGigabitEthernet1/1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface TenGigabitEthernet2/1/1
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface Vlan1
 no ip address
!
interface Vlan100
 ip address 192.168.100.253 255.255.255.0
!

Cisco 3750 muestra el árbol de expansión:

show spanning-tree

MST0
  Spanning tree enabled protocol mstp
  Root ID    Priority    32768
             Address     0004.ea84.5f80
             Cost        200000
             Port        53 (TenGigabitEthernet1/1/1)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32768  (priority 32768 sys-id-ext 0)
             Address     a44c.11a6.7c80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te1/1/1             Root FWD 2000      128.53   P2p


MST1
  Spanning tree enabled protocol mstp
  Root ID    Priority    1
             Address     a44c.11a6.7c80
             This bridge is the root
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    1      (priority 0 sys-id-ext 1)
             Address     a44c.11a6.7c80
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Te1/1/1             Desg FWD 2000      128.53   P2p

Cisco 3750 muestra el registro:

%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan100, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up

HP Switch 1:

; J9049A Configuration Editor; Created on release #T.13.71
vlan 1
   name "DEFAULT_VLAN"
   untagged 1-8,10,13-16,18-23,A1-A4
   ip address 100.100.100.17 255.255.255.0
   no untagged 9,11-12,17,24
   exit
vlan 100
   name "192.168.100"
   untagged 9,11-12,17,24
   tagged 1-8,10,13-16,18-23,A1-A4
   no ip address
   exit
vlan 21
   name "Users_2"
   tagged 1,A1-A4
   no ip address
   exit
vlan 40
   name "Cafe"
   tagged 1,4,7,A1-A4
   no ip address
   exit
vlan 250
   name "Firewall"
   tagged 1,4,7,A1-A4
   no ip address
   exit
vlan 70
   name "DMZ"
   tagged 1,4,7-8,13,A1-A4
   no ip address
   exit
spanning-tree
spanning-tree config-name "mstp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 40 70 100 250
password manager
password operator

HP Switch 1 show spanning tree:

 show spanning-tree

 Multiple Spanning Tree (MST) Information

  STP Enabled   : Yes
  Force Version : MSTP-operation
  IST Mapped VLANs : 2-39,41-69,71-99,101-249,251-4094
  Switch MAC Address : 0021f7-126580
  Switch Priority    : 32768
  Max Age  : 20
  Max Hops : 20
  Forward Delay : 15

  Topology Change Count  : 363,490
  Time Since Last Change : 14 hours

  CST Root MAC Address : 0004ea-845f80
  CST Root Priority    : 32768
  CST Root Path Cost   : 200000
  CST Root Port        : 1

  IST Regional Root MAC Address : 0021f7-126580
  IST Regional Root Priority    : 32768
  IST Regional Root Path Cost   : 0
  IST Remaining Hops            : 20

  Root Guard Ports     :
  TCN Guard Ports      :
  BPDU Protected Ports :
  BPDU Filtered Ports  :
  PVST Protected Ports :
  PVST Filtered Ports  :

                  |           Prio            | Designated    Hello
  Port  Type      | Cost      rity State      | Bridge        Time PtP Edge
  ----- --------- + --------- ---- ---------- + ------------- ---- --- ----
  A1              | Auto      128  Disabled   |
  A2    10GbE-CX4 | 2000      128  Forwarding | 0021f7-126580 2    Yes No
  A3    10GbE-CX4 | Auto      128  Disabled   |
  A4    10GbE-SR  | Auto      128  Disabled   |

Registro de conmutador 1 de HP: Eliminé los campos de fecha / hora porque son inexactos (no hay NTP configurado en estos switches)

00839 stp: MSTI 1 Root changed from 0:a44c11-a67c80 to 32768:0021f7-126580
00839 stp: MSTI 1 Root changed from 32768:0021f7-126580 to 0:a44c11-a67c80
00842 stp: MSTI 1 starved for an MSTI Msg Rx on port A4 from 0:a44c11-a67c80
00839 stp: MSTI 1 Root changed from 0:a44c11-a67c80 to 32768:0021f7-126580
00839 stp: MSTI 1 Root changed from 32768:0021f7-126580 to 0:a44c11-a67c80
00839 stp: MSTI 1 Root changed from 0:a44c11-a67c80 to ...

Configuración del switch 2 de HP:

; J9146A Configuration Editor; Created on release #W.14.49

vlan 1
   name "DEFAULT_VLAN"
   untagged 1,3-17,21-24,A1-A2,B2
   ip address 100.100.100.36 255.255.255.0
   no untagged 2,18-20,B1
   exit
vlan 100
   name "192.168.100"
   untagged 2,18-20
   tagged 1,3-17,21-24,A1-A2,B1-B2
   no ip address
   exit
vlan 21
   name "Users_2"
   tagged 1,A1-A2,B2
   no ip address
   exit
vlan 40
   name "Cafe"
   tagged 1,13-14,16,A1-A2,B2
   no ip address
   exit
vlan 250
   name "Firewall"
   tagged 1,13-14,16,A1-A2,B2
   no ip address
   exit
vlan 70
   name "DMZ"
   tagged 1,13-14,16,A1-A2,B2
   no ip address
   exit
logging 192.168.100.18
spanning-tree
spanning-tree 1 path-cost 500000
spanning-tree config-name "mstp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 40 70 100 250

Árbol de expansión HP Switch 2:

show spanning-tree

 Multiple Spanning Tree (MST) Information

  STP Enabled   : Yes
  Force Version : MSTP-operation
  IST Mapped VLANs : 2-39,41-69,71-99,101-249,251-4094
  Switch MAC Address : 0024a8-cd6000
  Switch Priority    : 32768
  Max Age  : 20
  Max Hops : 20
  Forward Delay : 15

  Topology Change Count  : 21,793
  Time Since Last Change : 14 hours

  CST Root MAC Address : 0004ea-845f80
  CST Root Priority    : 32768
  CST Root Path Cost   : 200000
  CST Root Port        : A1

  IST Regional Root MAC Address : 0021f7-126580
  IST Regional Root Priority    : 32768
  IST Regional Root Path Cost   : 2000
  IST Remaining Hops            : 19

  Root Guard Ports     :
  TCN Guard Ports      :
  BPDU Protected Ports :
  BPDU Filtered Ports  :
  PVST Protected Ports :
  PVST Filtered Ports  :

                  |           Prio            | Designated    Hello
  Port  Type      | Cost      rity State      | Bridge        Time PtP Edge
  ----- --------- + --------- ---- ---------- + ------------- ---- --- ----
  A1    10GbE-CX4 | 2000      128  Forwarding | 0021f7-126580 2    Yes No
  A2    10GbE-CX4 | Auto      128  Disabled   |
  B1    SFP+SR    | 2000      128  Forwarding | 0024a8-cd6000 2    Yes No
  B2              | Auto      128  Disabled   |

Registro HP Switch 2: Eliminé los campos de fecha / hora porque son inexactos (no hay NTP configurado en estos switches)

00839 stp: CST Root changed from 32768:0021f7-126580 to 32768:0004ea-845f80
00839 stp: IST Root changed from 32768:0021f7-126580 to 32768:0024a8-cd6000
00839 stp: CST Root changed from 32768:0004ea-845f80 to 32768:0024a8-cd6000
00839 stp: CST Root changed from 32768:0024a8-cd6000 to 32768:0004ea-845f80
00839 stp: CST Root changed from 32768:0004ea-845f80 to 32768:0024a8-cd6000
00435 ports: port B1 is Blocked by STP
00839 stp: CST Root changed from 32768:0024a8-cd6000 to 32768:0021f7-126580
00839 stp: IST Root changed from 32768:0024a8-cd6000 to 32768:0021f7-126580
00839 stp: CST Root changed from 32768:0021f7-126580 to 32768:0004ea-845f80

9
2017-12-06 14:58


origen




Respuestas:


¿Puedes cambiar el número de instancia MST a 0? Creo que esto puede estar causando su problema, MST ejecuta la instancia 0 de manera predeterminada, por lo que ha creado dos instancias, la instancia 1 con las vlans que ha asignado y la instancia 0 con todas las demás. a juzgar por su configuración de Cisco, solo necesita una instancia:

spanning-tree mst configuration
 name mstp
 revision 1
 instance 0 vlan 1, 40, 70, 100, 250
 spanning-tree mst 0 root primary

Es extraño que su raíz esté batiendo, pero solo ha establecido la prioridad para la instancia 1 no 0. Mueva todo a la instancia 0 y también establezca la prioridad de la instancia 0 de MST en los conmutadores de HP a un valor superior al predeterminado. Entonces, la raíz siempre será la 3750 mientras esté en la red.

En los conmutadores de HP:

spanning-tree
spanning-tree config-name "mstp"
spanning-tree config-revision 1
spanning-tree instance 0 vlan 1 40 70 100 250
spanning-tree priority 36864

El comando del costo de la ruta del árbol de expansión se configuró probablemente para evitar que HP2 se convierta en la raíz:

Sintaxis: spanning-tree <port-list> path-cost <auto | 1..200000000>

  Asigna un costo de puerto individual que el conmutador utiliza para determinar qué puertos están reenviando puertos en un árbol de expansión determinado. En la configuración predeterminada (automática), el conmutador determina el costo de la ruta de un puerto por el tipo de puerto:   -

  10 Mbps: 2000000   -

  100 Mbps: 200000   -

  1 Gbps: 20000   

Consulte “Nota sobre el costo de la ruta” en la página 4-17 para obtener información.   en la compatibilidad con dispositivos que ejecutan 802.1D STP para los valores de costo de ruta (Predeterminado: Automático).

Desde el Guía de gestión avanzada de tráfico de HPpágina 138. Si no agregó la declaración de costo de la ruta, la eliminaría y solo establecería la prioridad del puente más alta en el conmutador que desea que sea la raíz. Si ese es el Cisco entonces ya está configurado con mis comandos.


4
2017-12-07 16:11





Wow ... Después de toda la investigación, resultó que todo lo que faltaba era establecer el valor de instancia de MST 0 en un valor más bajo que el valor predeterminado. Una vez que lo configuré en 4096, todas las configuraciones del árbol de expansión comenzaron a funcionar como se esperaba, mostrando a los macs de Cisco como la raíz.

La solución de GerryEgan funcionaría ya que también habría cambiado la instancia de MST 0 a un valor más bajo. sin embargo, eventualmente me gustaría poder usar los dos enlaces de 10 gigas, uno para la VLAN 1 y otro para la VLAN 100. Esta configuración general se desarrolló con ese objetivo final en mente. No lo incluí en la pregunta, ya que en realidad no era pertinente, estaba desesperado por cualquier solución.

En resumen para configurar esta configuración utilicé:

Cisco 3750

spanning-tree mode mst
spanning-tree extend system-id
spanning-tree mst configuration
 name mstp
 revision 1
 instance 1 vlan 1, 40, 70, 100, 250
spanning-tree mst 1 priority 0
spanning-tree mst 0 priority 4096

Interruptores HP

spanning-tree
spanning-tree config-name "mstp"
spanning-tree config-revision 1
spanning-tree instance 1 vlan 1 40 70 100 250

3
2017-12-12 02:43