Pregunta Instalar Xvfb a través del repositorio yum - yum para Xvfb?


Estoy tratando de instalar Xvfb en un sistema RHEL 6.2 usando yum. Sin embargo, toda la ayuda que he encontrado dice:

    yum install Xvfb

o...

    yum install xorg-x11-server-Xvfb

Lo cual estoy seguro de que funcionaría si tuviera configurado el repositorio correcto, y supongo que no. Porque me sale el error:

    No package Xvfb available.

Los únicos repositorios que tengo en este sistema son redhat.repo y rhel-source.repo. ¿Qué repo contiene el paquete Xvfb?

¡Gracias!


23
2017-12-28 19:54


origen




Respuestas:


Umm, el paquete se llama "xorg-x11-server-Xvfb" en CentOS5.

Así que deberías usar la segunda opción, "yum install xorg-x11-server-Xvfb". Puede hacer "yum search xvfb", que también le da el nombre correcto del paquete.


31
2017-12-28 20:07



Probé ambos, ninguno de los dos funciona. La búsqueda no muestra paquetes coincidentes, y "yum install xorg-x11-server-Xvfb" me dice "No hay paquetes disponibles xorg-x11-server-Xvfb". - AWT
xorg-x11-server-Xvfb.i386 en mi máquina RHEL 5.5. Me pregunto si lo hicieron en 6.0. - Tim
Extraño. Es un paquete estándar de RHEL. Tal vez ejecute "yum clean" para borrar los datos locales? Esto podría ser algo sobre lo que tienes que molestar a RH. - cjc
@Tim. En CentOS6.2, veo "xorg-x11-server-Xvfb.i686 0: 1.10.4-6.el6_2.1" por lo que se deriva de fuentes estándar de RHEL. También se menciona en este documento oficial de salud reproductiva: rhn.redhat.com/errata/RHBA-2011-1816.html por lo que debería estar disponible en RedHat. Esto suena más como un problema con la configuración yum de Torgis. - cjc
Muy bien podría ser. Intenté yum clean all, yum search all xvfb y no obtengo nada. ¿Qué reposiciones has agregado en /etc/yum.repos.d? Acabo de ver mi red Hat y está en blanco. Eso probablemente no sea bueno. - AWT


Habilite los repositorios de contenido opcionales editando /etc/yum.repos.d/redhat-rhui.repo.

Abra la búsqueda de archivos para opcional - cambio habilitado = 0 a habilitado = 1

[rhui-REGION-rhel-server-optional]
name=Red Hat Enterprise Linux Server 7 Optional (RPMs)
mirrorlist=https://rhui2-cds01.REGION.aws.ce.redhat.com/pulp/mirror/content/dist/rhel/rhui/server/7/$releasever/$basearch/optional/os

enabled=1

Esto debería funcionar.


6
2017-09-17 23:25



solía sudo yum install --enablerepo rhel-7-server-optional-rpms xorg-x11-server-Xvfb. Solo una forma diferente de lograr lo que @Aamreeta sugiere aquí (sin editar el archivo yum.repos.d / redhat.repo). - Juan


Está disponible en los canales opcionales de cliente, estación de trabajo y servidor dentro de RHN: (Tenga en cuenta que las URL aquí le solicitarán su cuenta de soporte de redhat)

https://rhn.redhat.com/network/software/packages/name_overview.pxt?package_name=xorg-x11-server-Xvfb&archIdList=&archLabelList=&search_subscribed_channels=yes

Tendrá que configurar el derecho apropiado para usar uno de esos canales con su sistema, por supuesto.

Puede buscar paquetes en la siguiente URL si no está familiarizado con (o no le gusta) la GUI del Kit de Paquetes o la funcionalidad equivalente de yum:

https://rhn.redhat.com/rhn/channels/software/Search.do

¡aclamaciones!


4
2017-12-31 11:49



Pregunta tonta como seguimiento ... una vez que tenga una cuenta de soporte, ¿dónde coloco esa información en mi sistema para que funcionen estos repositorios de yum? - AWT
Tu enlace me da cualquier cosa ... Creo que ya no funciona ... - caarlos0


Gracias por explicar la solución ... por algún motivo, el enlace ftp para mí tenía un formato incorrecto y, por lo tanto, recibía errores como ...

ftp://ftp.redhat.com/pub/redhat/rhel/beta/6Server/x86_64/os/repodata/repomd.xml:[Errno 14] PYCURL ERROR 9 - "Server denied you to change to the given directory"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhel-beta. Please verify its path and try again

Observe la parte "6Server", que el directorio no existe o que algo está mal con lo que estaba haciendo.

De todos modos, terminé reemplazando $ releasever por ahora con "6" ftp://ftp.redhat.com/pub/redhat/rhel/beta/6/x86_64/os/repodata/repomd.xml

y por lo que puedo decir el "sudo yum install xorg-x11-server-Xvfb" instálelo bien


1
2018-02-17 19:31





Ok, lo he descubierto. La respuesta es agregar el repositorio rhel-beta, evitando así la necesidad de una suscripción RHN:

[rhel-beta]
name=Red Hat Enterprise Linux $releasever Beta - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/$basearch/os/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2
priority=1
exclude=*release

[rhel-beta-optional]
name=Red Hat Enterprise Linux $releasever Beta (Optional) - $basearch
baseurl=ftp://ftp.redhat.com/pub/redhat/rhel/beta/$releasever/optional/$basearch/os/
enabled=1
gpgcheck=0
#gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-beta-2
priority=1
exclude=*release

Trabajado como un encanto.


-1
2018-01-03 16:53



¿Dónde se supone que debes poner esta configuración? - slashdottir
No funcionó. - Robert